Home » Topic » Altering system file reboots phone

Altering system file reboots phone

Welcome. Forums BLOX2 Forum General Altering system file reboots phone

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by  Chris 2 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #1262

    Jed
    Participant

    Hello, I’m totally new to flashing/rooting/etc so my knowledge is limited to 12 hours of intense googling. If I’m missing something obvious I apologize in advance.

    I first rooted my phone (blu life one x2 mini) with TWRP and magisk on the stock rom. Titanium backup confirmed that the phone had successfully rooted but when I attempted to remove any of the system applications the phone would immediately crash and reboot. Thinking it might be a titanium issue I tried some other application and found that any modification to /system/ causes the phone to crash and reboot (deleting files or altering permissions).

    Thinking it might be due to some malaware or something with my stock rom I tried flashing a  different rom, but that hasn’t fixed it either. Currently I’m running lineageos (DraX wouldn’t boot) and I’m finding I have the same problem. I can install system applications but even though I have superuser permissions the device reboots when I try to remove them.

    Any help is appreciated.

    #1272

    Chris
    Participant

    It’s not malware or anything like that. Marshmallow introduced a system file protection which when you try to modify any system files it will freeze and reboot to prevent anything damaging the system files.

    There is no way (at least with the year plus of me search and modding) to fix this and all system modifications need to be done in recovery/twrp…WITH one expection. If you use Magisk to root your device you are able to edit system files while in the OS since Magisk mirrors the system files. This also has the added benefit if you like to tweak your phone all the time, doing all your mods through Magisk means your not actually modifying system files so if you really screw up your phone, all you have to do is uninstall Magisk to be back to stock system.

    I am going on no sleep so apologize for not going to in depth technically as  mind only half functioning but hope that helps!

     

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.