Home » Topic » Blue life one x2 uber driver gps

Blue life one x2 uber driver gps

Welcome. Forums BLOX2 Forum General Blue life one x2 uber driver gps

This topic contains 3 replies, has 3 voices, and was last updated by  Erick 1 week, 6 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #690

    Michael
    Participant

    I am not sure if this is the best place to ask but I figure you guys will know. I have a life one x 2 and a uber driver update a few months ago screwed the GPS up. The problem is between the uber driver app and GPS with any map out there including the uber map. It does not track right and instead of buying a new phone I thought I would try rooting and a custom ROM or whatever. I have never used one or needed to really but I will try anything to get it working again. Do you guys have any recommendations on what I should try and do to get uber driver working again with my life one x2 ?

    #692

    ieatgravity
    Keymaster

    Hey Michael,

     

    So to be clear, you are saying that the Uber Driving app update messed up the GPS functionality?

    Before running off and jumping into rooting and installing a custom ROM there are still a few other things I would try to debug the problem.

    1. Simply uninstalling the Uber driver app, rebooting and test the GPS with google maps. This will see if the Uber app is causing the issue.

    2. Have you tried a factory reset on the phone? Doing this WILL wipe all of your data, so be sure to make proper backups before doing. It will not touch your internal sdcard. This will allow you to start on a “fresh” set up of your phone. You will need to sign in and set up all your apps again.

    3. If it is still not working after a factory rest I would recommend flashing the STOCK ROM via QFIL. This will completely restore your phone to “Out of the box” software wise.

    If your GPS issue still persists I would check your warranty as you may have a defect in the phone.

     

    If you do decide to go along with rooting and custom ROMs then I would recommend you root with Magisk v12 (stable at the moment. DO NOT USE THE LATEST MAGISK v13 as it has been bricking devices) and using the latest Drax ROM. It is built on the stock ROM but has been enhanced to better compliment the hardware.

     

    I wish you the best and feel free to update me on the status!

    -ieatgravity

    #694

    Michael
    Participant

    I have tried resetting the device to factory and I have tried uninstalling the app. The GPS issues are only when I accept a ride. I have found one other person who posted in the uber forums about the same issue. I have also had multiple blue life one x2 phones and they all have this issue with the uber driver app. This started a few months ago with a uber update.  I will try rooting and see if it works. But I think I will just need a new phone to driver uber with.

    #695

    Erick
    Participant

    I would be letting Uber know that their update broke functionality. It’s not the first time they’re known for pushing something out without checking it.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Skip to toolbar