Home » Topic » Wifi Not Working

Wifi Not Working

Welcome. Forums BLOX2 Forum General Wifi Not Working

This topic contains 11 replies, has 3 voices, and was last updated by  Kerrigan 2 weeks, 6 days ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #795

    Joe
    Participant

    Please help, I accidentally wiped out my original, stock OS on the BLOX2 while using TWRP.  I tried both BLOX2core, and then DRAX ROMs, but both have an issue enabling WIFI.  WLAN will not toggle to the ON position. There doesn’t seem to be any way to get WiFi working because it will not hold the toggle in the ON position. Am I missing something like drivers that should accompany BLOX2core or DRAX ROMs?  Any help would be appreciated!

    #796

    Joe
    Participant

    Also, I’ve tried finding an original, STOCK ROM for BLOX2 but there does not seem to be one ANYWHERE.  Why is that?  I would be happy to find a working, original stock ROM for Blue Life One X2.

    #798

    simplegreen
    Participant

    Same issue here. Love any feedback to get wifi back up. Looks like it cant find a mac address

    #799

    simplegreen
    Participant

    having the same issue here. Love any feedback on getting wifi back. Looks like it cant find a mac address

    #801

    simplegreen
    Participant

    So i seemed to resolve my issue. Here’s step by step what i did.

      <li style=”list-style-type: none”>
    • booted into TWRP (i already had it on there from the Drax tool
    • went to mount and made sure i selected all the items twrp would allow me to select (system, data etc
    • once mounted i went to wipe and selected “Advance Wipe”
    • I selected all things i could wipe including internal storage (this may or may not be needed but i did it)
    • once I did the advanced wipe i was still in the wipe section and selected “Format Data”
    • i had to select “yes” this will take the encryption off
    • i think connected my phone to my PC while in TWRP and copied the stock rom from Blox2.com to the internal storage
    • oddly this copies the image to /sdcard (/sdcard1 is your ACTUAL sd card) confirm its there
    • i go to mount and make sure all the options are selected and make sure that i check select storage is opened and is on “internal storage’
    • Then i go to install, navigate to /sdcard and select the stock rom.
    • once i flash the rom and it all comes back up i finally have wifi back.

    disclaimer. i have no idea why this worked short of it being said in a post that i needed to de-encrypt before reflashing to stock.

    second. after i got wifi back, i was bold enough to walk through that entire process again and drop the Drax rom on. Same exact steps and i still have wifi. and a much cleaner interface.

    frustrating as hell but kinda fun. hth

    #803

    Joe
    Participant

    Simplegreen,

    I tried your instructions exactly, and ran through them twice, without success. After the phone reboots, it stays on the WLAN screen, but no networks show up, and I have to just Skip that setup page.  The phone will still not hold the ON position of the WiFi toggle.

    Does anyone else have any ideas?

    Thanks

    #804

    simplegreen
    Participant

    joe the only other thing i can think of i did was i was messing around with these instructions http://blox2.com/revert-to-stock-blu-life-one-x2/ i downloaded the drivers and QFIL. I was able to get my phone to finally boot to dload mode and get QFIL to see my phone (shows Qualcomm HS-USB QDLoader 9008 or similar). But i was never able to get it to show the firehose file or xml file so i abandoned it.  I did do this BEFORE i tried all of the above so maybe there is something there.

     

    #805

    Joe
    Participant

    I’ve been thinking that the problem is driver related, and went through hours of moving files into /persist, and even using a hex editor to hard code the MAC address, but none of it worked. I’ll try what you did and report back in a day or two. Thanks.

    #806

    Joe
    Participant

    Simple, some questions about your last post: How do you install the Qualcomm drivers, and what is download mode and how do you enable it?

    #807

    Joe
    Participant

    Simple, how do you install the Qualcomm drivers, and how do you put the phone in download mode?

    #808

    simplegreen
    Participant

    i dont think i directly installed anything to my phone. I guess what i was implying was that by downloading the QFIL and Qualcom PC installers (and installing them) then connecting to the phone via PC and the QFIL interface then TRYING to get the firehose/xml sorted somehow it maybe indirectly utilized the drivers (which is its own installable executable via PC). That page above (along with MANY of the other articles on this site) need some serious updating and detail. I get it .. pet project and all but articles with 10 bullet points consisting of “install drivers” leaves a LOT to be figured out randomly by the end user.

    #819

    Kerrigan
    Participant

    I’ve been beating my head against the wall trying to figure this out so i’m happy to find this thread.  I was only doing minor wipes using  TWRP and reflashing. It’s seems taking the extra step to do a major wipe and reinstalled the ROM fixed my issues. Including the internal storage in the wiping process and formatting seemed to fix it.

    • This reply was modified 2 weeks, 6 days ago by  Kerrigan.
    • This reply was modified 2 weeks, 6 days ago by  Kerrigan.
Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Skip to toolbar